Какая версия CakePHP совместима с php 5.4? (генерирует ошибки с помощью AjaxHelper)

Я разработал веб-сайт с использованием CakePHP 2.4, а сервер, на который я загрузил веб-сайт, использует PHP 5.4. Все работает правильно, но я использовал AjaxHelper и JavascriptHelper на сайте. Это генерирует предупреждения как:

Strict (2048): Declaration of JavascriptHelper::value() should be compatible with Helper::value($options = Array, $field = NULL, $key = 'value') [APP/View/Helper/JavascriptHelper.php, line 23]

Strict (2048): Declaration of JavascriptHelper::afterRender() should be compatible with Helper::afterRender($viewFile) [APP/View/Helper/JavascriptHelper.php, line 23]

Strict (2048): Declaration of AjaxHelper::afterRender() should be compatible with Helper::afterRender($viewFile) [APP/View/Helper/AjaxHelper.php, line 1398]

Мне не понятно, почему это происходит? Есть ли проблемы с версиями? Пожалуйста, помогите мне.

0

Решение

Как уже говорилось, сообщение содержит предложение изменить

afterRender

в

afterRender ($ viewFile)

внутри в файле, указанном в сообщении об ошибке. Не так сложно понять 🙂

l8erz

-D1G

0

Другие решения

http://api.cakephp.org/2.5/source-class-JsHelper.html#23-436

Скопируйте jshelpercode и вставьте его в папку view/helper/JsHelper.php

-1

По вопросам рекламы ammmcru@yandex.ru
Adblock
detector